dracoblue.net

mcrypt and PHP 5.3 on Ubuntu Jaunty

My dedicated server still runs on ubuntu jaunty. I wanted to move on to php 5.3 (php 5.2.16 was the final release of the php 5.2 series). The issue is: php 5.3 is not available in jaunty repositories, because it will stay at 5.2.

Installing php 5.3 was simple, just add to:

$ vim /etc/apt/sources.list

the following:

deb http://php53.dotdeb.org stable all 
deb-src http://php53.dotdeb.org stable all

Install the dotdeb pgp key:

# curl http://www.dotdeb.org/dotdeb.gpg | apt-key add -

Update the apt cache and upgrade php5:

# apt-get update
# apt-get install php5

But when you want to install phpmyadmin again now, it fails.

php5-mcrypt: Depends: libltdl3 (>= 1.5.2-2) but it is not installable

Luckily you can get that (mcrypt) by adding the lenny updates repository manually:

# vim /etc/apt/sources.list

add:

http://security.debian.org/debian-security lenny/updates main

Install the debian gpg:

# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 9AA38DCD55BE302B

Now update again:

# apt-get update

and install php5-mcrypt flawlessly:

# apt-get php5-mcrypt

I commented out the new sources.list entries after the install, because I don't need them to be checked on every update.

In articles, linux, php, ubuntu by @ 19 Dec 2010

comments powered by Disqus

Recent Files

Advertisement

Recent Dev-Articles

Read recently

About

Blogroll