dracoblue.net

Install pandoc 1.9 on ubuntu lucid/oneric

Don't install pandoc with apt-get. Follow those instructions to get the latest version, You need haskell-platform. Don't install haskell with apt-get, too. Use this guide

how to install haskell on ubuntu. As soon as you are done, you can install pandoc with this:

$ cabal update
$ cabal install pandoc

Remember to do this NOT with sudo, because you want to have cabal locally available with the current user. But if it fails with:

Resolving dependencies...
cabal: dependencies conflict: base-3.0.3.2 requires syb ==0.1.0.2 however
syb-0.1.0.2 was excluded because json-0.5 requires syb >=0.3.3

you did accidently installed haskell-platform with apt-get. Do

$ sudo apt-get remove haskell-platform

and follow the link from the beginning of this post!

In ubuntu by DracoBlue @ 10 Mar 2012

comments powered by Disqus

Recent Files

Advertisement

Recent Dev-Articles

About

Blogroll